Welcome, Guest. Please login or register.

Author Topic: i dont know if this is a bug with vvvvvv or a bug with ved but im reporting it  (Read 1688 times)

KlarTopic starter

  • tOLP2 Tester
  • Crewmate
  • **
  • Posts: 22
  • fucc whom? a. eeeee b. thirsty boi. c. he is comin
    • View Profile
    • tresspassers beware
When I make a level that uses ONLY the grey Warp Zone tileset, and opens with an internal script, for some reason, when I open the level in VVVVVV, all the entities in the starting room (and possibly further, I'll test) disappear! And that means I have to place a Start Position and Script Box linking to the load script every time I want to test a level! I'm using version 1.1.4(source).
[/rant]

Dav999

  • Administrator
  • Hyper Captain
  • *
  • Posts: 1599
    • View Profile
Can you send me the level file? I can't seem to reproduce it with what you said.

Do the entities still show up in Ved after saving or do they disappear, and if so, when do they disappear?

KlarTopic starter

  • tOLP2 Tester
  • Crewmate
  • **
  • Posts: 22
  • fucc whom? a. eeeee b. thirsty boi. c. he is comin
    • View Profile
    • tresspassers beware
The entities still show up in VED.
It's worse than I imagined.
If you have a level that does NOT use the grey warp zone tileset but warps in the starting room, then all entities there will disappear. If you have a level that does use the grey tileset and starts with an internal script, same thing.
Weird.
Also, I encountered something weird.
It happened continuously with other grey tileset levels of the same second criteria...
But for the problem level attached to the post, it doesn't.
Weird.
i use weird too much
P.S i like to give test levels weird names dont judge

Info Teddy

  • Ultra Captain
  • ********
  • Posts: 3141
    • View Profile
Do the work before we do the work.
« Reply #3 on: September 30, 2017, 11:20:38 AM »
When I make a level that uses ONLY the grey Warp Zone tileset, and opens with an internal script, for some reason, when I open the level in VVVVVV, all the entities in the starting room (and possibly further, I'll test) disappear! And that means I have to place a Start Position and Script Box linking to the load script every time I want to test a level! I'm using version 1.1.4(source).
[/rant]
>i dont know if this is a bug with vvvvvv or a bug with ved but im reporting it
Hey just a tip, don’t title bug reports this, it’s very uninformative and doesn’t exactly instill confidence in anyone reading it that it’s a problem with Ved. And if you aren’t sure, then test and make sure before posting anything.

Anyways, we seriously can’t reproduce this. And given that VVVVVV has hilarious differences between platforms, please post your OS.

On Linux with VVVVVV’s latest build, without touching the level at all with Ved and manually setting the tilecol to 6, I cannot get VVVVVV to magically make the entities disappear. And creating the level in Ved gives the same result, too.

Dav999

  • Administrator
  • Hyper Captain
  • *
  • Posts: 1599
    • View Profile
If the two levels you posted originally contained entities, and now they were unexpectedly removed, then that does sound worrying, but I've placed entities and internal scripts in both those levels and nothing bad happened.

Are you able to reproduce this yourself, or was it a one-time thing? If you can reproduce it, could you give very detailed instructions of every step we should take and what you see (preferably with only one possible interpretation) and/or screenrecord it?

KlarTopic starter

  • tOLP2 Tester
  • Crewmate
  • **
  • Posts: 22
  • fucc whom? a. eeeee b. thirsty boi. c. he is comin
    • View Profile
    • tresspassers beware
I run Windows Vista, and...
While it happened to me MANY times before I started this topic...
I just can't seem to reproduce it again...
I like using ellipses...

Info Teddy

  • Ultra Captain
  • ********
  • Posts: 3141
    • View Profile
It’s been very resolved.
« Reply #6 on: September 30, 2017, 04:15:54 PM »
While it happened to me MANY times before I started this topic...
I just can't seem to reproduce it again...
Huh, that’s really strange. Can we close this topic now?

Dav999

  • Administrator
  • Hyper Captain
  • *
  • Posts: 1599
    • View Profile
Ok, before we mark this resolved, could you tell me the steps you would have taken to reproduce it as well as you remember?

Something like this:
- Make new level in Ved, set first room to gray warp zone tileset, place start point and other entities
- Save in Ved
- Load in VVVVVV
- Be surprised that the entities are missing in VVVVVV, but exist in the Ved window you left open
- Reload the level in Ved
- The entities are now gone in Ved too

KlarTopic starter

  • tOLP2 Tester
  • Crewmate
  • **
  • Posts: 22
  • fucc whom? a. eeeee b. thirsty boi. c. he is comin
    • View Profile
    • tresspassers beware
Sorry for taking so long, but the entities DO appear in VED.

Dav999

  • Administrator
  • Hyper Captain
  • *
  • Posts: 1599
    • View Profile
Before or after reloading the level in Ved?

KlarTopic starter

  • tOLP2 Tester
  • Crewmate
  • **
  • Posts: 22
  • fucc whom? a. eeeee b. thirsty boi. c. he is comin
    • View Profile
    • tresspassers beware
After.

Dav999

  • Administrator
  • Hyper Captain
  • *
  • Posts: 1599
    • View Profile
Even in the levels you attached earlier in this topic? problem.vvvvvv only has a start point, titball.vvvvvv is empty. Even when examining the contents of the level file.

If you have a level which you can, at this point, open in VVVVVV where the entities don't show, but open in Ved where the entities do show, could you send me that specific level file?

Otherwise, please respond to this post:
Ok, before we mark this resolved, could you tell me the steps you would have taken to reproduce it as well as you remember?

Something like this:
- Make new level in Ved, set first room to gray warp zone tileset, place start point and other entities
- Save in Ved
- Load in VVVVVV
- Be surprised that the entities are missing in VVVVVV, but exist in the Ved window you left open
- Reload the level in Ved
- The entities are now gone in Ved too